
About Minitab 
(Rupali Akerkar) 
 
 
FOR PRACTICALS : 

 
Mintab is an easy-to-use statistical package which can carry out a wide variety of statistical tasks.  
 
There are three basic kinds of object that Minitab works with. 
Data column: This is the most frequently used object type in Minitab. Columns are denoted C1, 
C2, C3, etc. They each store a collection of observations relating to a particular variable. 
We will be using data columns 
 
Constants: These are denoted K1, K2, K3, etc., and each store a single number of interest. 
 
Data arrays:  These are matrices of numbers, and are denoted by M1, M2, M3, etc. All of the 
data columns, constants and data arrays relating to a particular problem are stored in a working 
environment called a worksheet. Worksheets can be saved to and loaded from disk, for later use. 
Several worksheets may be opened simultaneously, and these can be saved together as a project. 
 
 
There are two different ways to use Minitab. The simplest way is to select operations from 
Minitab’s menus using the mouse. The other way is to type commands directly into Minitab via 
the Session.( This we will use for macros!!!!!!) 
                                                      
Window. When you select an operation using the menus, this is automatically translated into a 
Minitab command, which is displayed in the session window (if commands are enabled — see 
later) before being executed — examining the command displayed in the session window is a 
good way to learn Minitab commands. Minitab commands generally accomplish one of three 
things.  

 They manipulate a worksheet,  
 They perform an analysis,  
 The results of which are displayed in the session window, or they produce a plot.  

 
Data entry and loading a worksheet 
 
When Minitab is first started, there are two main Mintab windows. One is the session window 
and the other main window is the Data or Worksheet Window. This allows you to view and edit 
the data columns of the current worksheet. Data can be entered directly into this window.  
  In Minitab, the data are stored in columns, which  are called C1,C2,... in the Worksheet window. 
The rows will contain individual cases. All variables can be divided into two types: 
• Numerical (or quantitative; Minitab calls them numeric) and 
• Categorical (or qualitative, Minitab calls them text). 
 
 



 
 
 
The space at the top of each column (directly below the column number) is provided for you to 
name the columns you use. You should get into the habit of always naming your columns, as it is 
easy to forget what each represents. After entering data, always check each entry carefully, as it is 
easy to make mistakes. 
 
OPEN a new project: 
You will see two parts: 
UPPER :  session 
 
LOWER : worksheet 
 
There is some data given with minitab for tutorial purpose for getting it on the work sheet. 
Press start  - press My computer – go to  local disk  C: - go to program files – Minitab 15 –  
English- sample data  - drag the sample data called Tumor. 
Check   :   see how the values are given. 
 
Time Size  
14 1,25  
16 1,90  
19 4,75  
21 5,45  
23 7,53  
26 14,50  
28 16,70  
30 21,00  
33 27,10  
35 30,30  
37 40,50  
41 51,40  
 
Remove this, do not save. 
 
 
EXAMPLE1: 
FOR demonstration, we will use data from example 11.4, (from H&R book) on  page 472. 
You will insert the data: 
C1           C2  
Item         Lifetimes(months) 
 
In first column write numbers 1 to 16. 
In second column write the lifetimes. 
 
 
 



 
 
 
 
 
Simple data summaries 
To obtain some useful summary statistics, select Stat → Basic Statistics → Display 
Descriptive Statistics,                     This will give the number of observations, mean, median, 
trimmed mean, standard deviation, standard error of mean, minimum, maximum, lower and upper 
quartiles. 
Descriptive Statistics: Lifetimes(months)  
 
Variable            N  N*   Mean  SE Mean  StDev  Minimum     Q1  Median 
Lifetimes(months)  16   0  81,64     6,69  26,78    31,70  65,20   81,45 
 
Variable               Q3  Maximum 
Lifetimes(months)  104,77   130,00 

 
 
Scatter plot 
A scatter plot can be produced by selecting Graph → Scatterplot → OK, then selecting the 
required y variable and the required x variable . Before clicking on OK, you may select Labels..., 
and enter a title. 
 If you wish to save plots, these may be saved individually, or as part of a project (see below). To 
save a plot, select it and then File → Save Graph As..., and give an appropriate filename . 
OR 
Right click the graph and cut and paste where you want. 
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Scatterplot of Lifetimes(months) vs Item

 
 
 
 
 



 
 
 
Histogram 
To produce a histogram, select Graph → Histogram → OK and the variable to be plotted .  
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Probability plot: 
Graph > probability plot 
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Normal - 95% CI

 
 
 



 
 
 
The empirical distribution function: 
 
Graph > empirical CDF 
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The empirical survivor plot. 
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Complete Data
Kaplan-Meier Method

 
 
 
 
 



 
 
 
 
The Kaplan –Meier Estimator 

/ Survival > Distribution Analysis (Right Censored) > Non parametric analysis 
aplan Meier ) 

he description is: 

Lifetimes(months)  
istribution Analysis: Lifetimes(months)  

censored value          16 

nparametric Estimates 

69397  68,5238  94,7637 

R = 36,7  Q1 = 65  Q3 = 101,7 

,0        1       1       0,0000  0,000000  0,000000  0,00000 

onparametric Cumulative Failure Plot for Lifetimes(months)  

 
Stat > Reliability
(K
 
 
T
 
Nonparametric Cumulative Failure Plot for 
D
 
Variable: Lifetimes(months) 
 
ensoring Information  Count C

Un
 
 
No
 
 
Characteristics of Variable 
 
            Standard   95,0% Normal CI 
ean(MTTF)     Error    Lower    Upper M

   81,6437   6,
 
edian = 75,2 M

IQ
 
 
Kaplan-Meier Estimates 
 
        Number  Number     Survival  Standard   95,0% Normal CI 
 Time  at Risk  Failed  Probability     Error     Lower    Upper 
 31,7       16       1       0,9375  0,060515  0,818892  1,00000 
 39,2       15       1       0,8750  0,082680  0,712951  1,00000 
 57,5       14       1       0,8125  0,097578  0,621250  1,00000 
 65,0       13       1       0,7500  0,108253  0,537828  0,96217 
 65,8       12       1       0,6875  0,115878  0,460383  0,91462 
 70,0       11       1       0,6250  0,121031  0,387784  0,86222 
 75,0       10       1       0,5625  0,124020  0,319426  0,80557 
 75,2        9       1       0,5000  0,125000  0,255005  0,74500 
 87,7        8       1       0,4375  0,124020  0,194426  0,68057 
 88,3        7       1       0,3750  0,121031  0,137784  0,61222 
 94,2        6       1       0,3125  0,115878  0,085383  0,53962 
101,7        5       1       0,2500  0,108253  0,037828  0,46217 
105,8        4       1       0,1875  0,097578  0,000000  0,37875 
109,2        3       1       0,1250  0,082680  0,000000  0,28705 
10,0        2       1       0,0625  0,060515  0,000000  0,18111 1

130
 
  

Nonparametric Survival Plot for Lifetimes(months)  
N



 
These graphs can be seen on Minitab windows. 

ven on course web page under the title: 
INITAB14 macros 

ired file in your folder. Do not copy it in C:, it is reserved for document 

eck your folder, double click it. -> 
ake a folder for TMA4275, and saved the required file. 

TB >  %M:\your name\TMA4274\TMA4275nelson.txt C3-C9 

nitab09\macros\TMA4275nelson.txt 

istribution Analysis: C3  

nsoring value: Censoring = 0 

nparametric Estimates 

69397  68,5238  94,7637 

R = 36,7  Q1 = 65  Q3 = 101,7 

 
 
For NELSON Plot : 
Follow instructions gi
M
 
NOTE: Copy the requ
and setting purposes. 
GO TO MY Computer  -> then On network Drives  ->  ch
m
 
Give commands in session window: 
M

 
 
MTB >  %M:\minitab09\macros\TMA4275nelson.txt C3-C9 
Executing from file: M:\mi
  

D
 
Variable: C3 
 
ensoring Information  Count C

Uncensored value          16 
 
Ce
 
 
No
 
 
Characteristics of Variable 
 
            Standard   95,0% Normal CI 
ean(MTTF)     Error    Lower    Upper M

   81,6437   6,
 
edian = 75,2 M

IQ
 
 
Kaplan-Meier Estimates 
 
        Number  Number     Survival  Standard   95,0% Normal CI 
 Time  at Risk  Failed  Probability     Error     Lower    Upper 
 31,7       16       1       0,9375  0,060515  0,818892  1,00000 
 39,2       15       1       0,8750  0,082680  0,712951  1,00000 
 57,5       14       1       0,8125  0,097578  0,621250  1,00000 
 65,0       13       1       0,7500  0,108253  0,537828  0,96217 
 65,8       12       1       0,6875  0,115878  0,460383  0,91462 
 70,0       11       1       0,6250  0,121031  0,387784  0,86222 
 75,0       10       1       0,5625  0,124020  0,319426  0,80557 
 75,2        9       1       0,5000  0,125000  0,255005  0,74500 
 87,7        8       1       0,4375  0,124020  0,194426  0,68057 
 88,3        7       1       0,3750  0,121031  0,137784  0,61222 



 94,2        6       1       0,3125  0,115878  0,085383  0,53962 
101,7        5       1       0,2500  0,108253  0,037828  0,46217 
105,8        4       1       0,1875  0,097578  0,000000  0,37875 
109,2        3       1       0,1250  0,082680  0,000000  0,28705 

0,0        2       1       0,0625  0,060515  0,000000  0,18111 11
130,0        1       1       0,0000  0,000000  0,000000  0,00000 

 

  130,0  3,38073  0,034023    0,0000 

Scatterplot of Survival Nelson vs Time  

 
 

 
 
 
 
 
 
 
 
 
Data Display  
 
            Cum Haz  Survival  Survival 
Row   Time   Nelson    Nelson        KM 
  1   31,7  0,06250  0,939413    0,9375 
  2   39,2  0,12917  0,878827    0,8750 
  3   57,5  0,20060  0,818244    0,8125 
  4   65,0  0,27752  0,757662    0,7500 
  5   65,8  0,36085  0,697082    0,6875 
  6   70,0  0,45176  0,636506    0,6250 
  7   75,0  0,55176  0,575935    0,5625 
  8   75,2  0,66287  0,515369    0,5000 
  9   87,7  0,78787  0,454812    0,4375 
 10   88,3  0,93073  0,394266    0,3750 
 11   94,2  1,09740  0,333739    0,3125 
 12  101,7  1,29740  0,273242    0,2500 
 13  105,8  1,54740  0,212801    0,1875 
 14  109,2  1,88073  0,152479    0,1250 

5  110,0  2,38073  0,092483    0,0625  1
 16
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aving and retrieving worksheets and projects 
itab, you will usually want to save the contents of your 

orksheet for future use. To save a worksheet, first click on it in order to make it active, and then 

 

 have produced, or the contents of the session window. To save your complete 
ile → Save 

te 

currently working on. However, they are less useful for long term data storage, as the project files 

Nelson Surv

 
 
Will also get these graphs.  

Scatterplot of Survival KM vs Time  
Scatterplot of Cum Haz Nelson vs Time 
 
 
 
 
 
 
 
Parametric Distribution: 
 
Stat > Reliability/ Survival> Distribution Analysis (Right censoring) 
> Exponential 
> Weibull 
> Lognormal 
 
S
When you have been working with Min
w
select File → Save Current Worksheet As. Note that under Windows XP, file names may be 
longer than 8 letters, may be of mixed case, and may contains spaces and hyphens. You should 
try to avoid using other symbols, especially those which have special meaning (such as \) and are
not permitted. Note that saving a worksheet only saves the worksheet contents. It does not save 
any plots you
workspace, including the session window, all open worksheets, and any plots, select F
Project ... and select an appropriate directory and file name. This can be re-loaded at a later da
by selecting File → Open Project..., or by clicking on the small yellow “open file” icon on the 
Minitab tool-bar. Projects are often more convenient than worksheets for a “project” you are 



tend to be very large, and so you may eventually run out of disc storage space. Worksheets must 
be re-loaded by selecting File → Open Worksheet — they can’t be opened by clicking on the 
open file icon on the toolbar. 
 
 
Printing and copying files and plots 
 
    In fact, you will usually want to “Copy-and-Paste” a plot, or some session window outpu
a Microsoft Word document, and then print the Word document

t into 
 when it is complete. In Word, it 

 easy to format output and re-size plots for more efficient use of paper. For example, it is easy 
 copy several plots into a Word document, and arrange them so that they all print together on a 

ingle page. 
Try this now by running Microsoft Word from the Start menu (Start → Programs → 
Office XP → Microsoft Word), without quitting Minitab. Then switch back to Minitab (click 
on the Minitab button on the task bar), select a Graph Window, and then choose Edit → Copy 
Graph. Switch back to Word (the Word button on the task bar) and Edit → Paste the graph into 
your Word document. By double-clicking on the graph you can resize it and edit it in other ways 
(such as adding a title).You can also copy bits of the Session Window into Word. Scroll back 
through your Session Window output to find a Stem-and-Leaf plot. Click and hold the mouse 
button at the top of the plot, and then holding down the button, drag the pointer down to the 
bottom of the plot, highlighting it in the process. 
Select Edit → Copy in Minitab then Edit → Paste in Word as before. If you are pasting a 
graph into a Word document containing lots of text, you may wish to control the way text wraps 
around it. For example, selecting the plot in your Word document and choosing Format → 
Object...→ Layout → Square → Left → OK is one possibility. 
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